镜像域名 doub.bid 提供给无翻墙能力的人访问,有能力的建议访问主域名:doub点io(防镜像替换 自己改点)
投稿文章 | 广告投放 | Telegram 群组 / 公告频道

『原创』CentOS/Debian/Ubuntu ShadowsocksR 单/多端口 一键管理脚本

Shadowsocks Toyo 971评论
文章目录
[显示]
本文最后更新于 2017年11月3日 11:13 可能会因为没有更新而失效。如已失效或需要修正,请留言!

最近经常有小白找我让我把他们安装ShadowsocksR服务端,一开始都是手动安装的,后来嫌麻烦,就打算用脚本,但是网上基本上只是安装一下就没了,只能算一键安装脚本,并不足够方便和适合懒人和小白,于是自己写了一个一键管理脚本,一键安装和一键管理的区别!


更多的Shadowsocks安装教程/一键脚本请看这里:Shadowsocks指导篇

本脚本的 二维码图片链接,是调用我自建的 二维码API 来生成二维码图片( http://doub.pw/qr/qr.php?text=xxx )。

当访问API页面后,PHP网页文件会把 GET参数( ?text=xxx ) 传递给JS脚本,浏览器会加载JS脚本,然后由JS脚本根据 GET参数的文本 生成二维码图片!图片是在你本地浏览器中生成,服务器中不存在图片!

请确定你信任我和我的脚本,否则请不要用我的脚本,少BB!

系统要求

CentOS 6+ / Debian 6+ / Ubuntu 14.04 +

推荐 Debian 7 x64,这个是我一直使用的系统,我的脚本在这个系统上面出错率最低。并且最容易安装锐速(锐速不支持OpenVZ)

CentOS根据大家的要求,加入了CentOS 6和7的支持,CentOS 7 自带防火墙问题(firewalld)自行解决,其他版本没有做测试。

脚本版本

Ver: 2.0.35

本脚本与另一个SSR脚本 『原创』ShadowsocksR MudbJSON模式多用户一键脚本 支持流量限制等 的区别是什么?

ssrmu.sh 脚本是单服务器多用户脚本,使用的是 SSR服务端的MudbJSON模式,可以给每个用户(端口)设置不同的加密方式/协议/混淆/限制速度/设备数限制/可用总流量等功能。即实现单服务器多用户流量管理等功能。

ssr.sh 则是单服务器单用户脚本,使用的是 SSR服务端的单用户配置方式,即使实现了多端口,但是还算不算多用户,不支持每个用户(端口)不同的加密方式/协议/混淆等,并且无法管理流量使用。

如何选择这两个脚本?

根据你的需求选择,比如你仅仅是 一个或两个人使用,并且不需要流量管理功能,那么选择 ssr.sh 好了。而如果很多人使用,并且都需要限制流量来管理,那你适合使用 ssrmu.sh ,所以自己看着选,多试试(两个脚本不能共存)

脚本特点:

目前网上的各个ShadowsocksR脚本基本都是只有 安装/卸载 等基础功能,对于小白来说还是不够简单方便,要修改账号配置还要手动修改文件,所以那些ShadowsocksR脚本只能称得上一键安装脚本。既然没有我满意的ShadowsocksR一键管理脚本,那么我就自己造喽,于是特意学了Shell,然后写出来了这个ShadowsocksR一键管理脚本

  1. 支持 限制 端口限速
  2. 支持 限制 端口设备数
  3. 支持 显示 当前连接IP
  4. 支持 显示 SS/SSR连接+二维码
  5. 支持 切换管理 单/多端口
  6. 支持 一键安装 BBR
  7. 支持 一键安装 锐速
  8. 支持 一键安装 LotServer
  9. 支持 一键封禁 垃圾邮件(SMAP)/BT/PT

安装步骤

简单的来说,如果你什么都不懂,那么你直接一路回车就可以了!

本脚本需要Linux root账户权限才能正常安装运行,所以如果不是 root账号,请先切换为root,如果是 root账号,那么请跳过!

sudo su

输入上面代码回车后会提示你输入当前用户的密码,输入并回车后,没有报错就继续下面的步骤安装ShadowsocksR。


v2.0.0 版本以后的脚本,请先卸载旧脚本ShadowsocksR服务端,再重新安装!

wget -N --no-check-certificate https://softs.fun/Bash/ssr.sh && chmod +x ssr.sh && bash ssr.sh

备用下载地址(上面的链接无法下载,就用这个):

wget -N --no-check-certificate https://raw.githubusercontent.com/ToyoDAdoubi/doubi/master/ssr.sh && chmod +x ssr.sh && bash ssr.sh

下载运行后会提示你输入数字来选择要做什么。

输入 1 ,就会开始安装ShadowsocksR服务端,并且会提示你输入Shadowsocks的 端口/密码/加密方式/ 协议/混淆(混淆和协议是通过输入数字选择的) 等参数。

如果安装过程中报错,请看 常见问题解决方法

如果协议是origin,那么混淆也必须是plain !

点击展开 查看更多

使用说明

运行脚本,

bash ssr.sh

输入对应的数字来执行相应的命令。

  请输入一个数字来选择菜单选项

 1. 安装 ShadowsocksR
 2. 更新 ShadowsocksR
 3. 卸载 ShadowsocksR
 4. 安装 libsodium(chacha20)
————————————
 5. 查看 账号信息
 6. 显示 连接信息
 7. 设置 用户配置
 8. 手动 修改配置
 9. 切换 端口模式
————————————
 10. 启动 ShadowsocksR
 11. 停止 ShadowsocksR
 12. 重启 ShadowsocksR
 13. 查看 ShadowsocksR 日志
————————————
 14. 其他功能
 15. 升级脚本
 
 当前状态: 已安装 并 已启动
 当前模式: 单端口

请输入数字(1-15):

当你为 单端口模式时,使用 7. 设置 用户配置 是 修改 单端口账号配置。

当你为 多端口模式时,使用 7. 设置 用户配置 是 添加/删除/修改 多端口账号配置。

文件位置

安装目录:/usr/local/shadowsocksr

配置文件:/etc/shadowsocksr/user-config.json

其他说明

ShadowsocksR 安装后,自动设置为 系统服务,所以支持使用服务来启动/停止等操作,同时支持开机启动。

  1. 启动 ShadowsocksR:/etc/init.d/ssr start
  2. 停止 ShadowsocksR:/etc/init.d/ssr stop
  3. 重启 ShadowsocksR:/etc/init.d/ssr restart
  4. 查看 ShadowsocksR状态:/etc/init.d/ssr status

ShadowsocksR 默认支持UDP转发,服务端无需任何设置。

本脚本已经集成了 安装/卸载 锐速(ServerSpeeder)开心版,但是是否支持请查看 Linux支持内核列表 。(锐速不支持OpenVZ)

v2.0.0 以前的旧版本下载地址:

点击展开 查看更多

ShadowsocksR目前支持的协议和混淆:

协议(Protocol):origin,auth_sha1_v4,auth_aes128_md5,auth_aes128_sha1,auth_chain_a,auth_chain_b

混淆(Obfs):plain,http_simple,http_post,random_head,tls1.2_ticket_auth,tls1.2_ticket_fastauth(需06/04日以后的服务端版本)

origin 和 plain 是原版,加粗的是推荐使用的。

如果你想要使用 tls1.2_ticket_fastauth 混淆插件,那么服务端选择 tls1.2_ticket_auth,客户端选择 tls1.2_ticket_fastauth 即可。

如果服务端 设置混淆参数为:tls1.2_ticket_auth_compatible (兼容原版)

那么客户端 可使用的混淆为:plain / tls1.2_ticket_auth / tls1.2_ticket_fastauth

tls1.2_ticket_authtls1.2_ticket_fastauth 的区别为,后者不会等待服务器回应,所以不会增加延迟。适合于,因为混淆插件增加延迟的原因不得不选择原版混淆 plain,但是又因为QOS等因素而处于延迟与干扰/限速等之间抉择的时候,可以选择 tls1.2_ticket_fastauth 客户端混淆插件!

使用阿里云/腾讯云等存着安全组或规则组一类外部防火墙的请注意

点击展开 查看更多

ShadowsocksR 端口限速中 单线程限速 和 端口总限速 的区别

注意:如果要使用脚本中的这个功能,需要重新下载脚本,并重装安装 2月15日 以后的ShadowsocksR服务端才行。

请查看这个文章:ShadowsocksR服务端 限制设备连接数 和 限制端口速度 的方法

解决 可使用原版协议,但无法使用ShadowsocksR协议 的问题

点击展开 查看更多

提示 Media change: please insert the disc labeled‘Debian GNU/Linux 7.0.0 Wheezy — Official amd64 CD 等信息是 apt源 的问题,更换 apt源

点击展开 查看解决办法

ShadowsocksR启动失败,日志提示:Exception: libsodium not found 的错误

这是你使用了 chacha20 系列加密方式,但是却没有安装 libsodium支持库,导致ShadowsocksR无法启动,运行脚本选择选项 4 安装 libsodium支持库即可,如果安装失败,请选择其他的加密方式,对速度影响不大。

提示wget: unknown host “softs.fun” 之类的错误

这是无法解析我的域名,多半是DNS的问题,请更换DNS为谷歌DNS。

点击展开 查看更多

提示 wget: command not found 的错误

这是你的系统精简的太干净了,wget都没有安装,所以需要安装wget。

点击展开 查看更多

升级脚本

升级脚本只需要重新下载脚本文件就可以了,会自动覆盖原文件。

定时重启

一些人可能需要定时重启ShadowsocksR服务端来保证稳定性等,所以这里用 crontab 定时。

点击展开 查看更多


本脚本只是本人的第一个Shell脚本学习练手作品,在逻辑结构上问题不少,大家遇到什么BUG请积极反馈!

更新日志

2017年11月03日,版本 v2.0.35

1. 修改 SSR服务端安装方式为:ZIP压缩包安装(考虑到SSR服务端不更新了,所以为了降低git依赖安装出错率,就改成zip压缩包了)。

2. 修改 JQ安装方式为:集成与SSR服务端文件夹内(减少了一个安装JQ的下载步骤,节省时间)。

2017年10月06日,版本 v2.0.34

1.恢复 libsodium以前安装方式。

2017年09月22日,版本 v2.0.33

1.修复 因为系统缺少automake,而libsodium安装失败的问题。

点击展开 查看更多更新日志


更多的Shadowsocks安装教程/一键脚本请看这里:Shadowsocks指导篇

转载请超链接注明:逗比根据地 » 『原创』CentOS/Debian/Ubuntu ShadowsocksR 单/多端口 一键管理脚本
责任声明:本站一切资源仅用作交流学习,请勿用作商业或违法行为!如造成任何后果,本站概不负责!

赞 (193)or打赏
发表我的评论
取消评论
表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址
(971)个小伙伴在吐槽
  1. 你好,我现在用这个脚本在pzea的香港vps上使用。最近老是出现google验证,说是检测到了网络中的异常流量,请问有办法解决吗?谢谢
    Yannic2017-11-21 16:56 (2天前)回复
    • 出现这种情况说明:你的IP做了什么违反谷歌规定的行为(可能是前任拥有者做的),可以考虑换IP但不一定解决,或者你的IP段全被谷歌拉黑了,这种情况换IP段也没用。
      解决办法只有一个,换一个没有被谷歌拉黑的IP。
      Toyo2017-11-22 13:17 (1天前)回复
  2. 脚本中似乎没有tls1.2_ticket_fastauth的插件?
    LYCX20152017-11-20 08:58 (3天前)回复
  3. 请问这个可以用IPV6吗,机器有IPV6地址但是用不了.测IPV6网站也测不出。
    a44778882017-11-19 18:42 (4天前)回复
    • ShadowsocksR服务端默认监听IPv6,而脚本并不会去影响这些,所以也都是支持的,并且脚本默认IPv4 IPv6都在防火墙开放了端口。
      这个网站,Ping你的VPS的IPv6地址,看一看是否可用,有时候IDC会分配IPv6地址,但没有分配IPv6网络。
      Toyo2017-11-20 00:11 (4天前)回复
  4. Toyo大佬,我用你的一键脚本一路回车加y,安装成功但是ssr和ss都能链接但是无法上网,用的是阿里云国际新加坡服务器。
    lz00442017-11-19 16:58 (4天前)回复
    • 阿里云请检查外部防火墙,后台自己找 规则组/安全组之类的选项。
      Toyo2017-11-19 17:14 (4天前)回复
  5. @toyo 老大看看什么情况,查了半天没找到,用SSTAP 绝地求生出现的 017-11-16 21:33:43 WARNING udprelay.py:477 IOError sendto 255.255.255.255:20000 by user 9000 2017-11-16 21:33:43 ERROR shell.py:50 [Errno 13] Permission denied 2017-11-16 21:33:48 WARNING udprelay.py:477 IOError sendto 255.255.255.255:20000 by user 9000 2017-11-16 21:33:48 ERROR shell.py:50 [Errno 13] Permission denied 2017-11-16 21:33:53 WARNING udprelay.py:477 IOError sendto 255.255.255.255:20000 by user 9000 2017-11-16 21:33:53 ERROR shell.py:50 [Errno 13] Permission denied 2017-11-16 21:33:58 WARNING udprelay.py:477 IOError sendto 255.255.255.255:20000 by user 9000 2017-11-16 21:33:58 ERROR shell.py:50 [Errno 13] Permission denied 2017-11-16 21:34:03 WARNING udprelay.py:477 IOError sendto 255.255.255.255:20000 by user 9000 2017-11-16 21:34:03 ERROR shell.py:50 [Errno 13] Permission denied 2017-11-16 21:34:08 WARNING udprelay.py:477 IOError sendto 255.255.255.255:20000 by user 9000 2017-11-16 21:34:08 ERROR shell.py:50 [Errno 13] Permission denied 2017-11-16 21:34:13 WARNING udprelay.py:477 IOError sendto 255.255.255.255:20000 by user 9000 2017-11-16 21:34:13 ERROR shell.py:50 [Errno 13] Permission denied 2017-11-16 21:34:18 WARNING udprelay.py:477 IOError sendto 255.255.255.255:20000 by user 9000 2017-11-16 21:34:18 ERROR shell.py:50 [Errno 13] Permission denied 2017-11-16 21:34:23 WARNING udprelay.py:477 IOError sendto 255.255.255.255:20000 by user 9000 2017-11-16 21:34:23 ERROR shell.py:50 [Errno 13] Permission denied 2017-11-16 21:34:28 WARNING udprelay.py:477 IOError sendto 255.255.255.255:20000
    xiao xiao2017-11-16 23:00 (7天前)回复
    • 似乎是 SSR服务端在运行中没有权限导致的,你不是通过ROOT用户运行的吗?或者说你当前账号不是ROOT用户吗?
      Toyo2017-11-17 12:16 (6天前)回复
      • 感谢@toyo 我是ROOT 权限,升级到2.035版,似乎解决了,没有提示过。 我是一个账号单端口无限制10人用,在一起打绝地求生,也没有卡过很流畅, 现在问题2017-11-19 10:27:22 ERROR shell.py:50 [Errno 107] Transport endpoint is not connected 2017-11-19 10:27:23 ERROR shell.py:50 [Errno 107] Transport endpoint is not connected 2017-11-19 10:27:23 ERROR shell.py:50 [Errno 107] Transport endpoint is not connected 2017-11-19 10:27:23 ERROR shell.py:50 [Errno 107] Transport endpoint is not connected 2017-11-19 10:28:18 ERROR shell.py:50 [Errno 107] Transport endpoint is not connected 2017-11-19 10:28:19 ERROR shell.py:50 [Errno 107] Transport endpoint is not connected 2017-11-19 10:28:19 ERROR shell.py:50 [Errno 107] Transport endpoint is not connected
        xiao xiao2017-11-19 10:45 (4天前)回复
        • 不清楚这个问题,大部分SSR服务端输出的错误日志我都不知道是什么意思以及怎么解决,因为SSR作者也没有对每个错误日志代码进行解释。
          Toyo2017-11-19 12:12 (4天前)回复
  6. 大佬,我想问下。我的一台vps上挂了一个网站。直接用这个vps搭建SS,锐速啥的会不会冲突啊。
    pengyuss2017-11-14 16:04 回复
    • 不会,只要端口区分开。
      Toyo2017-11-14 16:40 回复
  7. 安装脚本以后能够上外网 但是再次运行bash ssr.sh命令显示未安装 是怎么回事?
    不追随x2017-11-11 18:01 回复
    • 信息太少,无法判断。
      Toyo2017-11-11 19:05 回复
  8. 不能开启udp转发,请问怎么解决?
    球球2017-11-11 05:05 回复
    • SSR服务端默认开启UDP转发,无需任何设置,也没有可以设置的选项。
      我的脚本也默认开放了防火墙端口的TCP/UDP协议,所以如果UDP用不了,要么是IDC限制(可能性很低),要么是你的VPS有外部防火墙(例如 阿里云 腾讯云 谷歌云 微软云等云),要么你的运营商限制UDP(可能性较高),具体情况自行排除。
      Toyo2017-11-11 08:55 回复
  9. 用腾讯云香港搭建了个SSR不知道会不会被查水表啊?腾讯云对这方面有没有监管啊?
    Hello World2017-11-10 22:08 回复
    • 我只知道目前 阿里云 疑似开始封杀SS/SSR这些代理软件了,阿里云系统内都强制安装并运行了监控进程,官方美名其曰:保护服务器安全。
      Toyo2017-11-11 09:07 回复
  10. 感谢逗比,成功设置,我想学这方面的技术,请问该从哪里学起呢?
    Lemon2017-11-10 15:06 回复
    • “这方面的技术”哪方面?
      Toyo2017-11-10 16:27 回复
  11. 您好dalao,我已经按照文章安装 也确实安装成功了 但却无法访问google 不清楚哪里出了问题 用的是vultr的vps
    梦空2017-11-09 15:51 回复
  12. debian 7 如何定时重启锐速母公司版,因为此版效果最好但会假死,请大神回复下代码
    哈哈2017-11-09 14:09 回复
    • 安装Crontab:
      # CentOS系统
      yum update && yum install crond -y
      # Debian/Ubuntu系统:
      apt-get update && apt-get install cron -y
      
      然后按顺序依次输入以下代码(*/30代码 每30分钟执行一次):
      crontab -l > "crontab.bak"
      echo -e "\n*/30 * * * * /bin/bash /serverspeeder/bin/serverSpeeder.sh restart" >> "crontab.bak"
      crontab "crontab.bak"
      rm -r "crontab.bak"
      
      Toyo2017-11-09 22:27 回复
  13. 安装时显示如下 内容 [[email protected] ~]# wget -N --no-check-certificate https://raw.githubusercontent.com/ToyoDAdoubi/doubi/master/ssr.sh && chmod +x ssr.sh && bash ssr.sh --2017-11-08 02:43:31-- https://raw.githubusercontent.com/ToyoDAdoubi/doubi/master/ssr.sh Resolving raw.githubusercontent.com... failed: Temporary failure in name resolution. wget: unable to resolve host address “raw.githubusercontent.com” [[email protected] ~]#
    小咸鱼2017-11-08 10:59 回复
    • wget: unable to resolve host address “raw.githubusercontent.com”
      # 无法DNS解析Github的域名,可能是DNS的问题。
      
      https://doub.bid/ss-jc42/#提示wget: unknown host “softs.fun” 之类的错误
      Toyo2017-11-08 11:18 回复
      • 这个怎么解决呢?
        小咸鱼2017-11-08 11:47 回复
        • 链接给你了都不看?这种问题比较迷,大部分情况下,修改系统DNS就能解决,小部分情况,也不知道是什么原因,只能更换系统解决,具体什么系统能用,自行测试,和IDC有关。
          Toyo2017-11-08 12:34 回复
  14. 已安装libsodium,但无法使用xchacha20-ietf-poly1305,日志提示加密协议不支持,这要怎么解决?是因为这是py版的ssr嘛?还是必须要用libev的?
    aes2562017-11-07 19:46 回复
    • SSR不支持这个加密方式。
      Toyo2017-11-08 10:57 回复
  15. 大佬,想请问下,512M运存的ovz能否同时运行两个这样的脚本(也就是说双开)
    茫茫然2017-11-05 23:00 回复
    • 够,具体情况自行测试。
      Toyo2017-11-06 08:21 回复
      • 好的谢谢大佬#手动滑稽 :neutral:
        茫茫然2017-11-06 20:45 回复
      • 对了,还想请问下怎么双开脚本,有木有类似方案或者教程呢?😂
        茫茫然2017-11-06 21:42 回复
        • SSR服务端不能双开,如果要,可能需要修改SSR服务端的代码,否则会冲突。
          Toyo2017-11-07 11:22 回复
  16. ShadowsocksR服务端 压缩包 下载失败 是怎 么回事啊
    6662017-11-04 19:52 回复
    • 字面意思,下载服务端失败。
      Toyo2017-11-04 23:45 回复
  17. 请问您一下 安装BBR重启VPS之后,点击启动BBR 出现“检测内核最新版本失败 !”的提示 怎么办 我用的是digitalocean的服务器
    hemsworth2017-11-03 21:58 回复
    • 出现这个错误提示说明这个返回结果为空,或者链接内核仓库网页超时。
      wget -qO- "http://kernel.ubuntu.com/~kernel-ppa/mainline/" | awk -F'\"v' '/v[4-9].[0-9]*.[0-9]/{print $2}' |grep -v '\-rc'| cut -d/ -f1 | sort -V | tail -1
      
      Toyo2017-11-03 22:12 回复
  18. 问下哦,如果像搬瓦工那样自带bbr的,用了这个脚本会不会被锐速覆盖掉呢?
    kamen2017-11-03 19:00 回复
    • BBR是集成与内核中的一个功能代码,而锐速安装是需要特定内核和系统的,内核4.9以后的版本才支持BBR,这意味这无法安装锐速。
      Toyo2017-11-03 20:39 回复
  19. 设备数限制为1个,但是测试时发现同时能多个设备在线。不知道是否是bug?
    无名大侠2017-11-02 07:02 回复
    • 限制设备数必须是都是用SSR协议才能限制,如果兼容原版或者使用原版协议,那么将无法限制,而除了 auth_chain_* 系列的协议,其他的协议的设备数限制还有误差(不是实时计算),至于其他的原因,我就不清楚了。
      Toyo2017-11-02 07:54 回复
  20. 反馈bug:使用本脚本,选择数据9开启多端口模式,新增一个端口后,原来的端口不可用,新增的可用。
    无名大侠2017-11-01 22:20 回复
    • 我这边无法复现你说的问题。需要提供更详细的信息。客户端服务器链接统计提示什么[错误/超时/空连]?服务端日志提示什么?配置文件内容贴出来(cat /usr/local/shadowsocksr/user-config.json)。
      Toyo2017-11-02 07:56 回复
  21. 谷歌经常要人机验证有啥办法解决没,腾讯首尔的机子
    2017-11-01 18:37 回复
    • 出现人机验证,说明谷歌把你的IP识别为 机器人访问,这种往往是你的IP或IP段因为什么原因进了谷歌的黑名单,这无解。
      Toyo2017-11-01 21:49 回复
  22. 2017-10-31 12:34:37 WARNING  auth.py:176 auth_sha1_v2: no inactive client
    2017-10-31 12:34:37 INFO     auth.py:355 auth_sha1_v4: auth fail, data 5dfdf759dce0aa8aa6672a00030e706d69722e33672e71712e636f6d0050
    2017-10-31 12:34:52 INFO     tcprelay.py:1358 port 80 connections down to 25
    2017-10-31 12:35:01 WARNING  auth.py:176 auth_sha1_v2: no inactive client
    2017-10-31 12:35:01 INFO     auth.py:355 auth_sha1_v4: auth fail, data 76fdf759c59284c83846eb00030e3230382e36372e3232322e3232320035
    2017-10-31 12:35:09 ERROR    shell.py:50 IP 127.0.0.1 is in forbidden list, when connect to 127.0.0.1:1080 via port 8080 by UID 8080
    2017-10-31 12:35:09 ERROR    tcprelay.py:812 exception from ::ffff:122.96.123.151:53621
    2017-10-31 12:35:15 WARNING  auth.py:176 auth_sha1_v2: no inactive client
    2017-10-31 12:35:15 INFO     auth.py:355 auth_sha1_v4: auth fail, data 84fdf759c59284c83946eb00030e3230382e36372e3232322e3232320035
    2017-10-31 12:35:15 ERROR    tcprelay.py:1097 invalid hostname: 08.67.222.2225Ngrapfacebookcom208.67.222.22253when handling connection from ::ffff:49.118.78.224:35786
    Xshell2017-10-31 12:35:38 WARNING  auth.py:176 auth_sha1_v2: no inactive client
    2017-10-31 12:35:38 INFO     auth.py:355 auth_sha1_v4: auth fail, data a1fdf759986662761b1d4200018ccf7f3901bb
    
    23332017-10-31 12:37 回复
  23. 最近几天在多个服务器上出现自动关闭的情况,只能重新启动。两个debian7,一个debian8,非常频繁。。开的是多端口模式,80.443和8080,2台兼容1台不兼容原版协议,加密是chacha20,协议是auth v4混淆tls1.2。服务器负载也是正常的
    23332017-10-31 12:10 回复
    • 如果只是 SSR服务端 自动关闭,那么这点信息是无法看出什么的。
      Toyo2017-10-31 16:47 回复
      • 是的,只是SSR服务端自动关闭,以前用单端口没出现过这种情况。。同一个系统
        23332017-10-31 22:26 回复
  24. 请问为什么我也是这样搭建的。可是youtube的速度只有2000.看别人的都10000多。这是什么情况造成的。
    baozi2017-10-31 10:43 回复
    • 影响速度的因素很多,别人的速度是别人的,你们两个不一样的地方很多,速度自然存在差距。同一个服务器,你可能100KB/S 别人可能就是1000KB/S,全国各地差别很多,要找到适合自己的服务器,就自己慢慢买慢慢试,谁都帮不了你。
      Toyo2017-10-31 10:51 回复
      • 好的,自己慢慢的摸索摸索吧 ,手机上面速度还不错,就是电脑上不行。
        wander2017-10-31 13:42 回复
  25. 请问这个设置好了,二维码什么的是不是直接就发到逗比的网站上了,这样岂不是别人都可以连接了?
    wander2017-10-30 13:35 回复
    • 你理解 二维码图片在线生成API 的概念吗?本文章一开头就解释了。
      Toyo2017-10-30 17:06 回复
      • 不好意思,没注意看开头,光顾看正文了,好东西,收藏了👌🏻
        wander2017-10-30 18:04 回复
  26. 逗比,我想知道,ssr 的脚本能不能用在 ss 的客户端上?如果不开混淆?
    feng2017-10-30 10:18 回复
    • SSR服务端如果是原版协议/混淆,或者兼容原版的协议/混淆,那么SS/SSR客户端都可以链接。
      Toyo2017-10-30 17:15 回复
  27. 请问可以在CentOS系统下用你的脚本安装BBR吗?
    马萨2017-10-28 22:12 回复
    • 我的SSR脚本内的BBR功能是我另外写的有个BBR脚本,不支持CentOS系统。
      Toyo2017-10-28 23:17 回复
  28. 你好,为什么用ssr.sh一键搭建后手机可以正常用,电脑端就是用不了?设置没有问题。
    eli2017-10-27 13:44 回复
    • 手机能用,说明账号(服务器、SSR服务端)没问题,如果你电脑和手机是同一个网络(比如WIFI),那么网络也没问题,你电脑不能用基本上就是电脑自身问题。
      Toyo2017-10-28 08:51 回复
  29. 老铁你的ssr脚本,我安装后,还是连接不上,开了全局,ip能ping通
    wq2017-10-26 14:06 回复
    • 如果是阿里云、腾讯云、谷歌云、微软云、亚马逊云这类需要设置 外部防火墙。
      SSR客户端的 服务器链接统计中,提示什么[错误/超时/空连]?
      无法连接有很多情况可以导致,需要提供大量信息排除,自行排除
      Toyo2017-10-27 00:08 回复
  30. 您好, 请问shadowsocksR版本的端口选择的是非443端口,那么混淆可以选择tls1.2_ticket_auth吗?还是说选择tls1.2_ticket_auth就必须是443端口呢?因为一般443端口用的SSL!
    BK2017-10-25 19:15 回复
    • 没有这个规定,端口任意。
      Toyo2017-10-26 01:59 回复
  31. 我是centos 6的系统,功能使用正常,但限制设备数不起作用,我把设备数设置为了2个,但测试了3个设备都可以同时连接使用。我服务器的加密 : aes-128-ctr,协议: auth_sha1_v4,混淆 : tls1.2_ticket_auth ,请toyo指导一下,是哪里出了问题,非常感谢!
    昌昌2017-10-24 12:13 回复
    • 和系统没关系,限制设备数必须是都是用SSR协议才能限制,如果兼容原版或者使用原版协议,那么将无法限制,而除了 auth_chain_* 系列的协议,其他的协议的设备数限制还有误差(不是实时计算),至于其他的原因,我就不清楚了。
      Toyo2017-10-24 20:31 回复
  32. 请问 显示依赖 Git 安装失败,多半是软件包源的问题,请检查 !是什么原因啊
    您好2017-10-23 22:53 回复
  33. 请问怎么查看安装的SSR server的版本? 听说版本低的会被请去喝茶
    螃蟹2017-10-23 10:28 回复
  34. 另外我用了大侠给的goflyway脚本,64M小鸡无压力,上网很流畅,就是不知道安全性怎么样?就怕被封。我可是买了3年的不能退款。
    skynet2017-10-21 16:27 回复
  35. GFW这次变高了,刚重装了一下SS,发现昨晚被封的端口又可以用了。但这次建好了SS却不敢用,怕再次被封就是永久的,甚至IP都会被封。恳求大侠给出一个装SSR的方案!谢谢了!
    skynet2017-10-21 16:26 回复
  36. [email protected]:~# yum -bash: yum: command not found 也可能是没有yum,怎么装呢?
    skynet2017-10-21 14:48 回复
    • yum 是CentOS 系统的包管理器, apt-get 是Debian/Ubuntu系统的包管理器,先确定你的系统,这两个都是各自系统自带的。
      Toyo2017-10-21 14:57 回复
      • 让大神见笑了!我是Debian 7 X64 apt-get是有的,但是安装不了,可能64M内存太小了。有没有手动安装的方法?
        skynet2017-10-21 16:10 回复
        • 手动安装就是 源码编译安装了,这种方式对系统性能要求(CPU、内存等)更高,甚至如果你没有编译需要的环境,你还需要安装编译环境,而安装编译环境有需要 apt-get 方式安装,至于手动安装相对小白也是麻烦很多,要安装一大堆依赖,依赖都是一个套一个,错一个就会无法编译安装其他软件。
          Toyo2017-10-21 20:08 回复
  37. Preconfiguring packages ... E: Sub-process /usr/bin/dpkg exited unexpectedly [错误] 依赖 Git 安装失败,多半是软件包源的问题,请检查 ! 请问这是什么原因?我的vps64M内存不够用吗?还是github的原因?
    skynet2017-10-20 20:30 回复
    • E: Sub-process /usr/bin/dpkg exited unexpectedly
      dpkg 进程意外退出,这个软件是用来安装/卸载/管理软件的,意外退出要么是某些地方设置有问题,要么是内存不足被系统Kill了。
      
      Toyo2017-10-21 00:26 回复
      • 那肯定是内存不足了。大侠能给个小内存的一键脚本吗?我试过了,SS服务端能装,但是没用一会就被GFW封了端口了。只有SSR,小心用的话,不会被封。
        skynet2017-10-21 01:47 回复
        • 你这个VPS,一开始安装依赖(yum install xxx/apt-get install xxx)都能内存不足被杀掉,那是性能有多么差劲。。。依赖都装不上,第一步都过不去。你可能需要清理一下没用的进程什么的。
          Toyo2017-10-21 14:17 回复
          • 请问怎么清理呢?估计是ovz超兽的太厉害了。有什么办法呢,就指着这个搭梯子了!
            skynet2017-10-21 14:47 回复
            • 先自己区分 ps -ef 没用的进程(不要问我),然后找到进程的PID(第二列的数字),然后 kill -9 pid数字 (例如 kill -9 2333)
              Toyo2017-10-21 14:56 回复
1 6 7 8